آموزش CCNAآموزش شبکهسیسکو

آموزش CCNA : قابلیت Etherchannel چیست و پیاده سازی Etherchannel

EtherChannel یک تکنیکی است که به شما امکان را می دهد تا پورت اترنت چندگانه را در یک پورت منطقی ترکیب کنید. بنابراین، به شما کمک می کند پهنای باند پورت های مختلف را ترکیب کنید. علاوه بر این، در صورت failure شدن ۱ Port، افزونگی نیز فراهم می شود. برای مثال، یک سناریو را در نظر بگیرید که در آن شما Fa0/1 interface و Fa0/2 را که هر یک تا ۱۰۰ مگابیت در ثانیه از پهنای باند پشتیبانی می کنند، در یک پورت منطقی (EtherChannel 1) به نام LogicalPort1 در نظر بگیرید. پهنای باند از پورت ۴۰۰ LogicalPort1 مگابیت در ثانیه خواهد بود. این همان چیزی است که Aggregation لینک نامیده شده است. علاوه بر این، اگر یکی از interface شما مانند Fa0/1 از گروه کانال کاهش یابد، interface دیگر مانند Fa0/2 هنوز هم قادر به ارائه اتصال خواهد بود. این چیزی است که به نام redundancy نامیده می شود. تکنولوژی EtherChannel همچنین به عنوان

  • NIC Teaming در مایکروسافت
  • Link Aggregation در سیسکو
  • Ethernet Bridge در لینوکس

شناخته می شود. در این پست، ما توضیح خواهیم داد که چگونه EtherChannel را پیکربندی کنید.

پیکربندی EtherChannel در سیسکو

در پیکربندی EtherChannel باید به نکات زیر توجه کنیم:

  1. در پیکربندی ترتیب قرار گرفتن پورت های فیزیکی نباید حتما به ترتیب باشد یا حتی پورت ها بر روی یه Module باشد
  2. همه پورت های شرکت کننده در گروه باید دارای یک سرعت و duplex باشند.
  3. همه پورتهای شرکت کننده باید به صورت فعال یا enable باشند.
  4. در EtherChannel پروتکلهای PAgP و LACP با یکدیگر سازگار نمی باشند.

Cisco’s GigaStack , FlexStack و … هرگز نباید بعنوان یک قسمتی از Etherchannel تنظیم بشوند به این خاطر که این Stacking پورت ها هر کدام به منظور خاصی فعال شده اند و با قابلیت EtherChannel سازگار نمی باشند.

برای اجرای تکنیک EtherChannel می توانید از هر یک از روش های زیر استفاده کنید:

PAgP مخفف پروتکل Port Aggregation Protocol است . یک پروتکل انحصاری شرکت سیسکو می باشد و در صورتی می توانیم از این پروتکل استفاده کنیم که تجهیزات دو طرف برای اتصال Cisco باشد و وظیفه این پروتکل مدیریت و برقراری کانال EtherChannel می باشد.

LACP مخفف پروتکل Link Aggregation Control Protocol است. این یک پروتکل استاندارد است. این پروتکل مربوط به شرکت خاصی نیست ولی توسط شرکت سیسکو و سایر شرکتها پشتیبانی میشود و در صورتی که تجهیزات ما مربوط به شرکت های مختلفی هست می توانیم از این پروتکل برای برقراری ارتباط استفاده کنیم.

Static هیچ پروتکل خاصی نیازی ندارد و مذاکره بین پورت اترنت به صورت دستی انجام می شود.

انواع مد های EtherChannel :

Mode

Protocol

توضیحات

Auto

PAgP

 در این مد هیچ پیام PAgP از طرف اینترفیس ارسال نمیشود ولی آماده پاسخگویی به پیام های PAgP از سوی سوئیچ مقابل میباشد و قادر به آغاز PAgP Negotiation نیست.

Desirable

PAgP

در این مد اینترفیس ها پیام های PAgP را ایجاد و به سمت سوئیچ مقابل ارسال میکند و قادر به آغاز PAgP Negotiation می باشد.

ON

Etherchannel

در این حالت لینک آپ میشود بدون اینکه پروتکلی negotiate کند. این مد تنها به دیوایسی متصل میشود که دقیقا همین تنظیمات را داشته باشد.

Active

LACP

در این مد اینترفیس ها پیام های LACP را ایجاد و به سمت سوئیچ مقابل ارسال میکند و قادر به آغاز LACP Negotiation می باشد.

Passive

LACP

در این مد هیچ پیام LACP از طرف اینترفیس ارسال نمیشود ولی آماده پاسخگویی به پیام های PAgP از سوی سوئیچ مقابل میباشد و قادر به آغاز LACP Negotiation نیست.

 

پیکره بندی EtherChannel در سیسکو

سناریویی که قرار است پیاده سازی کنیم چیزی شبیه به تصویر زیر است که از سوئیچ دو لینک را با هم به صورت Etherchannel  قرار می دهیم

Etherchannel on Cisco IOS Switch
Etherchannel on Cisco IOS Switch

Switch1> enable
Switch1# configure terminal
Switch1(config)# interface range fasttethernet0/1 -2
Switch1(config-if-range)# switchport mode access
Switch1(config-if-range)# switchport access vlan 10
Switch1(config-if-range)# channel-group 5 mode desirable
Switch1(config-if-range)# end

با دستور بالا اول دو اینترفیس ۱ و ۲ را انتخاب کرده و سپس آن ها را در یک Vlan 10 قرار می دهیم، و سپس عدد channel-group را ۵ قرار می دهیم (این عدد بین ۱ تا ۴۸ به صورت اختیاری می باشد)  و مد آن را بر اساس جدول بالا و نیازمان انتخاب می کنیم، ما اینجا بر روی desirable قرار داده ایم.

نکته: با دستور channel-group 5 به صورت خودکار port-channel 5 ساخته می شود ولی در صورت نیاز میتوان قبل از این کار با دستور زیر port-channel 5 را ساخت:

Switch(config)#interface port-channel 5

حال تنظیمات را در سوئیچ دوم انجام می دهیم

Switch2> enable
Switch2# configure terminal
Switch2(config)# interface range fasttethernet0/1 -2
Switch2(config-if-range)# switchport mode access
Switch2(config-if-range)# switchport access vlan 10
Switch2(config-if-range)# channel-group 2 mode auto
Switch2(config-if-range)# end

در دستور بالا تمام مواد مثل چیزی است که در سوئیچ اول زدیم فقط به دلخواه مد channel-group را روی auto قرار دادیم تا فقط زمانی فعال شود که درخواست از سوئیچ اول برای سوئیچ دوم ارسال شود.

نکته: حتما لازم نیست عدد channel-group در هر دو سوئیچ یکی باشد (مثل سناریوی ما) ولی بهتر است برای شناسایی راحتر این عدد را یکی قرار دهیم

با استفاده از دستور زیر اطلاعات مفیدی از port-channel دستگاه را می توانید ببینید

switch# show port-channel summary

Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator

M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port

Number of channel-groups in use: 1
Number of aggregators: 1

Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
۱۲ Po12(SU) - Fa0/1(P) Fa0/2(P)

SU: به معنی آن است که به صورت Layer2 فعال است و اگر RU باشد یعنی در حالت Layer3 قرار دارد

(P): به این معنی است که هر دو سمت به درستی فعال می باشند اگر(I)باشد یعنی پورت مورد نظر هنوز فعال نشده است و یا متوقف شده است

برای فعال کردن Etherchannel در سئویچ های لایه سه یا MLS ها فقط کافیه وارد رنج اینترفیس های خود شده و از دستور زیر استفاده کتید

switch(config-if-range)#no switchport

switch(config-if-range)#channel-group 2 mode on

حالا میتوانید به صورت زیر به Etherchannel خود ای پی دهید

switch(config)#interface port-channel 2
switch(config-if)#ip address 192.168.12.1 255.255.255.0

پیشنهاد میکنم برای مطالعه بیشتر کتاب تنظیمات و معرفی EtherChannel را مطالعه نمایید.

دانلود نسخه PDF
منبع
tosinso.com
برچسب ها

نوشته های مشابه

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

دکمه بازگشت به بالا
بستن
بستن