آموزش CCNAآموزش MTCNAآموزش شبکهسیسکومیکروتیک

آموزش CCNA : پروتکل PPP چیست و آموزش پیکربندی و تنظیمات PPP در سیسکو

40 درصد تخفیف ویژه تا یک هفته

پروتکل PPP یک پروتکل WAN می باشد که در لایه 2 بوسیله Encapsulate کردن فریم ها جهت اننتقال بر روی لینک های فیزیکی مانند: کابل های سریال، کابل های نوری و … عمل می کند. پروتکل PPP یک پروتکل استاندارد می باشد و نسبت به دیگر پروتکل WAN یعنی HDLC خصوصیات و مزایای بیشتری را در اختیار ما قرار می دهد.

تعدادی از خصوصیات آن که در HDLC در دسترس نمی باشند، شامل:

  • یکی از خصوصیات PPP مدیریت کیفیت لینک می باشد. PPP توانایی مانیتور کردن کیفیت لینک را دارد و هر زمان که تعداد خطاها در لینک ارتباطی زیاد شود، لینک را shutdown می کند.
  • در این پروتکل نیاز به احراز هویت می باشد که توسط PAP یا CHAP صورت می گیرد.

عملکرد PPP بر اساس ۳ پارامتر صورت می گیرد:

  1. کپسوله کردن یا همان Encapsulation فریم ها توسط HDLC
  2. استفاده از LCP یا Link Control Protocol برای برقراری، پیکربندی و تست لینک
  3. استفاده از NCP یا Network Control Protocols برای برقراری ارتباط با پروتکل های لایه 3

Link Control Protocol – LCP

پروتکل LCP اصلی ترین پروتکلی می باشد که PPP از آن برای عملکرد خود استفاده می کند. LCP در بالاترین لایه یعنی لایه 1 عمل کرده و در جهت برقراری، پیکربندی و تست لینک مورد استفاده قرار می گیرد. این پروتکل همچنین برای برقراری ارتباط با دیگر خصوصیات PPP مانند احراز هویت، تشخصی خطا پس از برقراری لینک مورد استفاده قرار می گیرد.

Network Control Protocol Layer

همانطور که در بالا نیز گفته شد وظیفه اصلی NCP امکان برقراری ارتباط بین PPP که یک پروتکل لایه ۲ می باشد با دیگر پروتکل ها در لایه 3 مانند : IP , IPX , APPLE TALK است.

PPP Authentication

PPP از دو پروتکل اهراز حویت PAP و CHAP پشتیبانی می نماید.

PAP کوتاه شده عبارت Password Authentication Protocol است که از آن به عنوان ساده ترین پروتکل احراز هویت یاد می کنند. این پروتکل از Handshake دو مرحله ای یا 2-Way Handshake جهت Authentication بهره می برد. کلمه های عبور در آن به صورت Plain Text یا متن ساده رد و بدل می شوند. این بدان معنی ست که امنیت PAP بسیار پایین است. اما در مقایسه با HDLC یک گام جلوتر محسوب می شود.

مورد دیگری که PAP را به ساده ترین پروتکل احراز هویت تبدیل کرده است این موضوع می باشد که Password ها تنها در شروع ارتباط رد و بدل و بررسی می شوند و بعد از آن Session بدون نیاز به بررسی دوباره کلمه عبور باز خواهد ماند.

در تصویر زیر 2 مرحله احراز هویت  را در Password Authentication Protocol مشاهده می نمایید.

معرفی پروتکل احراز هویت PAP - Password Authentication Protocol
معرفی پروتکل احراز هویت PAP – Password Authentication Protocol

خوشبختانه امنیت PPP به استفاده از روش PAP برای احراز هویت محدود نمی شود. پروتکل CHAP متد به نسبت پیچیده تری است که از 3-Way Handshake یا احراز هویت سه مرحله ای بهره می برد و کلمه عبور در آن به صورت HASH رد و بدل می گردد. CHAP یا Challenge Handshake Authentication Protocol از HASH  با رمزنگاری MD5 استفاده می نماید. در ابتدا HASH به Node دیگر ارسال می شود و نود دیگر نیز یک HASH را در پاسخ ارسال می کند. اگر هر دو HASH یکسان باشند ارتباط پذیرفته می شود.

در تصویر زیر سه مرحله گفته شده را مشاهده می نمایید.

معرفی پروتکل احراز هویت CHAP - Challenge Handshake Authentication Protocol
معرفی پروتکل احراز هویت CHAP – Challenge Handshake Authentication Protocol

پروتکل PPPOE یا Point-to-Point Protocol over Ethernet چیست ؟

پروتکل PPPOE یا Point-to-Point Protocol over Ethernet چیست ؟

بدون شک شما با واژه PPPOE یا سوال PPPOE چیست؟ در دنیای شبکه بارها و باها برخورد داشته اید و راحت از کنار آن گذشته اید و شاید هم برای اولین بار است که با آن برخورد کرده اید ولی لحظه ای صبر و تامل کنید چراکه ما واقعاً میخواهیم پاسخ این سوال را در ذهن شما بدهیم که حقیقتاً PPPOE چیست؟ و چرا اینقدر PPPOE در دنیای شبکه به عنوان یک پروتکل مهم و کاربردی تلقی می گردد و چرا عبارت PPPOE چیست؟ در گوگل یکی از عباراتی است که بیشترین جستجو را دارد؟ برای پاسخ به سوال باید در ابتدا بگوییم که PPPOE یا همان Point-to-Point Protocol over Ethernet یک پروتکل است. پروتکل PPPOE در شبکه به صورت خودکار به دنبال Access Point هایی که میتوانیم به آن وصل شویم ، میگردد و با ساخت یک کانکشن pppoe و با داشتن user و pass به راحتی میتوان به آن وصل شد.

PPPOE چیست؟

اگر شما به کلمات اختصار پروتکل PPPOE که برگرفته از point to point protocol over Ethernet که شاخه ای از پروتکل PPP می باشد، توجه کنید شاید کارکرد و معنای پروتکل PPPOE را بفهمید. خب برای آشنایی بیشتر ، پروتکل PPPOE را به دوبخش PPP و OE تقسیم می کنیم و در ادامه به توضیح درباره پروتکل PPPOE و کارکرد آن خواهیم پرداخت.

  1. PPPOE یک پروتکل استاندارد جهت برقراری ارتباط بین دو نقطه می باشد.
  2. از PPP یا همان point to point protocol برای برقراری ارتباط برروی مودم های Dial-Up استفاده می شد که که کار آن در مجموع امکان تبادل داده بین دو شبکه، دو نقطه یا همان دو Point می باشد اما باید بدانید که پروتکل PPPOE در فریم اترنت Encapsulate می شود.
  3. OE یا همان Over Ethernet به معنی استفاده چندین کاربر از خط اترنت می باشد.
  4. PPPOE برروی لایه ۲ یا همان لایه Data Link می باشد، کار می کند پس بنابراین بخوبی با IPv4 و IPv6 سازگاری دارد.
  5. پروتکل PPPOE به دلیل عدم نیاز کاربر به ساخت کانکشن و تنظیمات آن، بیشترین کاربرد را در ISP ها یا همان شرکتهایی که به شما خدمات اینترنت نظیر ADSL را ارائه میدهند، دارا می باشد پس بهتر است بدانید به طور معمول بیشتر تنظیمات PPPOE Server در سمت ISP ها انجام شده و تنظیمات PPPOE Client در سمت کاربران و به صورت معمول برروی روتر سازمان نظیر سیسکو ، میکروتیک یا مودم ها (در صورت استفاده برای کاربران خانگی) انجام می گیرد.
  6. پروتکل PPPOE یک پروتکل امن بوده که فشرده سازی ، رمزنگاری و احراز هویت را برای شما به وجود می آورد.
  7. کارکرد PPPOE جهت برقراری ارتباط بین دو نقطه و یا دو پورت اترنت به این صورت است که IP برروی یک کانکشن PPP قرارمی گیرد و ارتباط را بین دو نقطه برقرار میکند و از کانکشن PPP که در ادامه به پیکربندی تمامی این موارد خواهیم پرداخت، به عنوان یک کانکشن مجازی Dial up، بین نقاط شبکه استفاده می شود.

PPP MULTILINK یا MLPPP چیست؟

PPP MULTILINK یا MLPPP چیست؟

PPP MULTILINK یا MLPPP چیزی شبیه به EtherChannel می باشد. یعنی می تواند دو یا چند لینک ارتباطی را به یک لینک ارتباطی تبدیل کند.

سناریوی PPP با پروتکل احراز هویت PAP در سیسکو

ما یک سناریوی ساده داریم که قرار است بین دو روتر R1 و R2 که از طریق یک پروت سریال به هم متصل هستن به کمک PPP و PAP ارتباط بر قرار کنیم.

PPP

تنظیمات به شکل زیر می باشد:

روتر R1:

R1(config)#username nextadmin-r2 password 123
R1(config)#interface serial 1/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#encapsulation ppp
R1(config-if)#ppp authentication pap
R1(config-if)#ppp pap sent-username nextadmin-r1 password 321

نکته: در خط اول ما یوزر و پسورد سمت روتر R1 رو ساختیم یعنی همان یوزر و پسوردی که R2 باید برای R1 ارسال کند تا توسط روتر R1 تایید شود.

نکته: در خط اخر ما یوزر و پسوردی که در روتر R2 وارد کرده ایم را می نویسیم تا روتر R1 توسط روتر R2 تایید شود.

روتر R2:

R2(config)#username nextadmin-r1 password 321
R2(config)#interface serial 1/0
R2(config-if)#ip address 192.168.1.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#encapsulation ppp
R2(config-if)#ppp authentication pap
R2(config-if)#ppp pap sent-username nextadmin-r2 password 123

نکته: در خط اول ما یوزر و پسورد سمت روتر R2 رو ساختیم یعنی همان یوزر و پسوردی که R1 باید برای R2 ارسال کند تا توسط روتر R2 تایید شود.

نکته: در خط اخر ما یوزر و پسوردی که در روتر R1 وارد کرده ایم را می نویسیم تا روتر R2 توسط روتر R1 تایید شود.

سناریوی PPP با پروتکل احراز هویت CAHP در سیسکو

این سناریو هم دقیقا مثل بالایی می باشد با این تفاوت که بجای PAP از CHAP استفاده می کنیم.

PPP

تنظیمات به شکل زیر می باشد:

روتر R1:

R1(config)#username nextadmin password 123
R1(config)#interface serial 1/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#encapsulation ppp
R1(config-if)#ppp authentication chap
R1(config-if)#ppp chap hostname nextadmin
R1(config-if)#ppp chap password 123

روتر R2:

R2(config)#username nextadmin password 123
R2(config)#interface serial 1/0
R2(config-if)#ip address 192.168.1.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#encapsulation ppp
R2(config-if)#ppp authentication chap
R2(config-if)#ppp chap hostname nextadmin
R2(config-if)#ppp chap password 123

سناریوی MLPPP در سیسکو

این سناریو ما MLPPP یا multilink PPP را پیاده سازی می کنیم.

سناریوی MLPPP در سیسکو
سناریوی MLPPP در سیسکو

تنظیمات به شکل زیر می باشد:

روتر R1:

R1(config)#interface multilink1
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#ppp multilink
R1(config-if)#ppp multilink group 1
R1(config-if)#exit
R1(config)#interface serial 1/0
R1(config-if)#no shutdown
R1(config-if)#encapsulation ppp
R1(config-if)#ppp multilink
R1(config-if)#ppp multilink group 1
R1(config-if)#exit
R1(config)#interface serial 1/1
R1(config-if)#no shutdown
R1(config-if)#encapsulation ppp
R1(config-if)#ppp multilink
R1(config-if)#ppp multilink group 1

روتر R2:

R2(config)#interface multilink1
R2(config-if)#ip address 192.168.1.2 255.255.255.0
R2(config-if)#ppp multilink
R2(config-if)#ppp multilink group 1
R2(config-if)#exit
R2(config)#interface serial 1/0
R2(config-if)#no shutdown
R2(config-if)#encapsulation ppp
R2(config-if)#ppp multilink
R2(config-if)#ppp multilink group 1
R2(config-if)#exit
R2(config)#interface serial 1/1
R2(config-if)#no shutdown
R2(config-if)#encapsulation ppp
R2(config-if)#ppp multilink
R2(config-if)#ppp multilink group 1

سناریوی PPPOE در سیسکو

در این سناریو فکر کنید شما یک سرویس از یک ISP خریداری کرده اید و حالا شما به عنوان یک کاربر می خواهید به ISP متصل شوید و اینترنت خریداری شده را استفاده کیند، با این شرایط شما در روتر خود که قرار است به ISP متصل شود باید به شکل زیر عمل کنید:

اول از همه شما نیاز به یک interface dialer 1 دارید:

R1(config)#interface dialer 1

با دستور زیر می توانید IP را به صورت خودکار دریافت کتید (می توانید در صورت نیاز به صورت دستی نییز وارد کنید)

R1(config-if)#ip address negotiated

با دستورات زیر ما اول یک Pool برای خود ایجاد می کنیم و سپس encapsulation را فعال می کنیم، این که از pap استفاده کنیم یا چیز دیگر بستگی به تنظیمات سمت ISP شما دارد (ما از PAP استفاده کردیم)، و در آخر یوزر و پسوردی که از ISP برای سرویس خود دریافت کرده اید را وارد می کنید:

R1(config)#interface dialer 1
R1(config-if)#ip address negotiated
R1(config-if)#dialer pool 1
R1(config-if)#encapsulation ppp
R1(config-if)#ppp authentication pap callin
R1(config-if)#ppp pap sent-username nextadmin password 123123

حالا باید این dialer ساخته شده را به یک اینترفیس متصل کرد:

R1(config)#interface fastEthernet 0/0
R1(config-if)#no shutdown
R1(config-if)#pppoe-client dial-pool-number 1

کار تمام است فقط اگر نیاز به دیفالت روت داشتید می توانید به صورت زیر آن را وارد کنید:

R1(config-if)#ip route 0.0.0.0 0.0.0.0 dialer 1

 

بعضی از دستورات Show که ممکن است به شما در رفع خطا کمک کند نیز به صورت زیر است:

show ppp interfaces
show ppp sso alerts
show ppp sso state
show ppp sso summary
show interfaces
show interfaces serial
show ppp multilink

و در آخر دستورات مهم PPP نیز در زیر قرار داده ایم:

clear ppp sso state

clear ppp statistics

encapsulation ppp

group

multi-router aps

peer ipv4 address

ppp authentication

ppp chap password

ppp chap refuse

ppp ipcp dns

ppp ipcp neighbor-route disable

ppp ipcp peer-address default

ppp max-bad-auth

ppp max-configure

ppp max-failure

ppp max-terminate

ppp ms-chap hostname

ppp ms-chap password

ppp ms-chap refuse

ppp multilink multiclass

ppp multilink multiclass local

ppp multilink multiclass remote apply

ppp pap refuse

ppp pap sent-username password

ppp timeout authentication

ppp timeout retry

redundancy

security ttl

show ppp interfaces

show ppp sso alerts

show ppp sso state

show ppp sso summary

ssrp group

ssrp location

ssrp profile

 
منبع
networkuser.irtechtik.comhushplus.ir
برچسب ها

نوشته های مشابه

پاسخی بگذارید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

دکمه بازگشت به بالا
بستن
بستن