آموزش CCNAآموزش شبکهسیسکو

آموزش CCNA : ارتباط بین Vlan ها به کمک InterVLAN Routing

40 درصد تخفیف ویژه تا یک هفته

VLANها برای جدا سازی ترافیک شبکه، افزایش امنیت شبکه و تقسیم یک شبکه بزرگ به چندین شبکه کوچک استفاده می شود. ما می دانیم که سیستم ها متعلق به یک VLAN نمی توانند با سیستم های متعلق به سایر VLAN ها ارتباط برقرار کنند مگر اینکه نام VLAN و VLAN ID با آنها منطبق نباشد. با این حال، یک روش به نام InterVLAN مسیریابی است که اجازه می دهد تا VLAN های مختلف با یکدیگر ارتباط برقرار کنند. به منظور برقراری ارتباط بین InterVLAN، شما نیاز به یک دستگاه لایه 3 مانند روتر یا سوئیچ لایه 3 دارید.

Encapsulation dot1Q برای ارتباط InterVLAN استفاده می شود. در این پست، ما توضیح خواهیم داد که چگونه InterVLAN را روی روترها و سوئیچهای سیسکو پیکربندی کنید. سناریوی ما به شکل زیر می باشد.

Cisco InterVLAN Routing Scenario

سناریوی ما به این شکل است که دو تا پی سی داریم که یکی  در Vlan10 با آی پی 192.168.10.10 و یکی در Vlan20 با ای پی 192.168.20.20 قرار دارد و سوئیچ ما نیز به یک روتر متصل می باشد.

خوب حالا ما وارد روتر خود شده و بر روی اینترفیس fa/0/0 خود دوتا Sub Interface ایجاد می کنیم و سپس encapsulation dot1Q را نیز بر روی هر Sub Interface فعال می کنیم و در آخر به هر Sub Interface یک آی پی در رنج شبکه Vlan مورد نظر می دهیم.

برای وارد شدن و یا ایجاد Sub Interface یک عدد به دلخوا بعد از آدرس اینترفیس به صورت نقطه و عدد مورد نظر وارد می کنیم

interface FastEthernet0/0.10

عدد 10 بعد از dot1Q شماره Vlan ما می باشد

encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0

interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.20.1 255.255.255.0

آشنایی با روش SVI – Switch virtual interface

در این سناریو که مثل بالا می باشد دیگر ما روتر نداریم و فقط از یک سوئیچ لایه 3 استفاده می کنیم. به کمک این روش ما به هر Vlan یک IP داده و خود سوئیچ کار مسیریابی ما را انجام می دهد.

SVI Switch virtual interface
SVI Switch virtual interface

برای این کار وارد سوئیچ شده و دستورات زیر را وارد می کنیم

او از همه قابلیت روتینگ را روی سوئیچ فعال می کنیم

Switch(config)#ip routing

سپس برای هر  یک Vlan ساخته و به هر Vlan یک آی پی می دهیم، کار تمام است.

Switch(config)#interface vlan 10
Switch(config-if)#ip address 192.168.10.1 255.255.255.0
Switch(config-if)#no shutdown

Switch(config)#interface vlan 20
Switch(config-if)#ip address 192.168.20.1 255.255.255.0
Switch(config-if)#no shutdown

 

VLAN Command Reference, Cisco IOS XE Release 3.6E (Catalyst 3850 Switches)

E

Editing Commands

C

clear vtp counters
client vlan

D

debug
debug platform
debug sw-vlan
debug sw-vlan ifs
debug sw-vlan notification

I

interface vlan

S

show platform vlan
show vlan
show vtp
show wireless vlan group
switchport priority extend
switchport trunk
switchport voice vlan

V

vlan
vlan dot1q tag native
vtp (global
vtp (interface configuration)
vtp primary

W

wireless broadcast

برچسب ها

نوشته های مشابه

یک نظر

پاسخی بگذارید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

دکمه بازگشت به بالا
بستن
بستن