آموزش CCNAآموزش شبکهسیسکو

آموزش CCNA : پیاده سازی پروتکل مسیریابی OSPF در سیسکو

ما میخواهیم به معرفی و کانفیگ OSPF بپردازیم، اواس‌پی‌اف (به انگلیسی: OSPF) یک پروتکل مسیریابی برای شبکه‌ها است که از الگوریتم مسیریابی وضعیت پیونداستفاده می‌کند و در زمرهٔ پروتکل‌های مسیریابی داخلی قرار می‌گیرد. OSPF در یک سامانهٔ مستقل(AS) کار می‌کند که در RFC 2328) 1998) به صورت نسخهٔ دوم برای IPv4 تعریف می‌شود.

OSPF Neighbor States & OSPF Neighbor Forming Process
OSPF Neighbor States & OSPF Neighbor Forming Process

پروتکل OSPF از الگوریتم دیکسترا برای یافتن کوتاه‌ترین مسیر استفاده می‌کند. نوع متریک یا هزینهٔ مسیر، پهنای باند است، یعنی مسیر با پهنای باند بیشتر انتخاب می‌شود. شمارهٔ فاصلهٔ مدیریتی یا AD (به انگلیسی: Administrative Distance) برای این پروتکل 110 است. آدرس مالتی‌کست آن 224.0.0.5است و آدرس مالتی‌کست DR یا روتر انتخابی 224.0.0.6 است.

 

 

ما در پست “آموزش CCNA : معرفی کامل روتینگ و Dynamic Routing” به صورت کامل درباره پروتکل OSPF و روش کار این پروتکل و هر بحث تئوری در رابطه با این پروتکل صحبت کرده ایم ، پس قبل از این که این مطلب را ادامه دهید ، آن پست سایت رو مطالعه نمایید.

در این پست ما میخواهیم یک سناریو را انجام دهیم.

سناریوی OSPF در سیسکو و کانفیگ OSPF
سناریوی OSPF در سیسکو و کانفیگ OSPF

 

خوب مثل همیشه اول از همه تنظیمات اولیه روتر ها و سوئیچ ها رو انجام می دهیم.

اول روتر Core-Router کانفیگ می کنیم:

Core-Router(config)#interface loopback 1
Core-Router(config-if)#ip address 10.1.10.1 255.255.255.0

Core-Router(config)#interface loopback 2
Core-Router(config-if)#ip address 10.1.11.1 255.255.255.0

Core-Router(config)#interface loopback 3
Core-Router(config-if)#ip address 10.1.12.1 255.255.255.0

Core-Router(config)#interface loopback 4
Core-Router(config-if)#ip address 10.1.13.1 255.255.255.0

Core-Router(config)#interface loopback 5
Core-Router(config-if)#ip address 10.1.14.1 255.255.255.0

Core-Router(config)#interface ethernet 0/0
Core-Router(config-if)#ip address 172.18.0.1 255.255.255.0
Core-Router(config-if)#no shutdown

Core-Router(config)#interface serial 4/1
Core-Router(config-if)#ip address 172.18.13.1 255.255.255.0
Core-Router(config-if)#no shutdown

Core-Router(config)#interface serial 4/2
Core-Router(config-if)#ip address 172.18.11.1 255.255.255.0
Core-Router(config-if)#no shutdown

Core-Router(config)#interface serial 4/0
Core-Router(config-if)#ip address 172.18.12.1 255.255.255.0
Core-Router(config-if)#no shutdown

کانفیگ روتر R2 :

R2(config)#interface gigabitEthernet 0/0
R2(config-if)#ip address 172.18.0.2 255.255.255.0
R2(config-if)#no shutdown

R2(config)#interface loopback 1
R2(config-if)#ip address 10.1.2.2 255.255.255.0

کانفیگ روتر R3 :

R3(config)#interface gigabitEthernet 0/0
R3(config-if)#ip address 172.18.0.3 255.255.255.0
R3(config-if)#no shutdown

R3(config)#interface loopback 1
R3(config-if)#ip address 10.1.3.3 255.255.255.0

کانفیگ روتر R4 :

R4(config)#interface ethernet 0/0
R4(config-if)#ip address 172.18.3.4 255.255.255.0
R4(config-if)#no shutdown

R4(config)#interface serial 4/0
R4(config-if)#ip address 172.18.13.4 255.255.255.0
R4(config-if)#no shutdown

R4(config)#interface loopback 1
R4(config-if)#ip address 10.4.1.4 255.255.255.0

کانفیگ روتر R5 :

R5(config)#interface gigabitEthernet 0/0
R5(config-if)#ip address 172.18.3.5 255.255.255.0
R5(config-if)#no shutdown

R5(config)#interface loopback 1
R5(config-if)#ip address 10.4.2.5 255.255.255.0

کانفیگ روتر R6 :

R6(config)#interface gigabitEthernet 0/0
R6(config-if)#ip address 172.18.3.6 255.255.255.0
R6(config-if)#no shutdown

R6(config)#interface loopback 1
R6(config-if)#ip address 10.4.3.6 255.255.255.0

کانفیگ روتر R7 :

R7(config)#interface serial 4/0
R7(config-if)#ip address 172.18.11.7 255.255.255.0
R7(config-if)#no shutdown

R7(config)#interface loopback 1
R7(config-if)#ip address 10.2.1.7 255.255.255.0

R7(config)#interface ethernet 0/0
R7(config-if)#ip address 172.18.1.7 255.255.255.0
R7(config-if)#no shutdown

کانفیگ روتر R8 :

R8(config)#interface gigabitEthernet 0/0
R8(config-if)#ip address 172.18.1.8 255.255.255.0
R8(config-if)#no shutdown

R8(config)#interface loopback 1
R8(config-if)#ip address 10.2.2.8 255.255.255.0

کانفیگ روتر R9 :

R9(config)#interface gigabitEthernet 0/0
R9(config-if)#ip address 172.18.1.9 255.255.255.0
R9(config-if)#no shutdown

R9(config)#interface loopback 1
R9(config-if)#ip address 10.2.3.9 255.255.255.0

کانفیگ روتر R10 :

R10(config)#interface loopback 1
R10(config-if)#ip address 10.3.1.10 255.255.255.0

R10(config)#interface serial 4/0
R10(config-if)#ip address 172.18.12.10 255.255.255.0
R10(config-if)#no shutdown

تا این مرحله ما فقط تنظیمات IP هر روتر و اینترفیس های همان روتر رو وارد کرده ایم، از اینجا به بعد وارد تنظیمات OSPF می شویم

کانفیگ OSPF

کانفیگ OSPF روتر Core-Router :

Core-Router(config)#router ospf 1

نکته: در پست قبلی ما باید برای تمام روتر هایی که از EIGRP استفاده می کردن یک AS ثابت انتخاب می کردیم ولی در OSPF می توانیم از Process ID های (معادل AS در EIGRP) متفاوت استفاده کنیم. با دستور router ospf 1 ما هم OSPF را فعال کرده ایم و هم Process ID آن را 1 قرار داده ایم.

سپس با دستور زیر ما شبکه های متصل به روتر Core-Router را وارد می کنیم:

Core-Router(config-router)#network 172.18.0.0 0.0.255.255 area 0

نکته: ما بجای وارد کردن تک تک 172.18.0.0 شبکه های با /24 که با wild card به صورت 0.0.0.255 نوشته می شود از /16 که با wild card به صورت 0.0.255.255 نوشته می شود استفاده کردیم.

نکته: بعد از نوشت wild card ما باید area را مشخص کنیم که در اینجا ما از area 0 را وارد می کنیم.

Core-Router(config-router)#network 10.1.0.0 0.0.255.255 area 0

کانفیگ OSPF روتر R2 :

R2(config)#router ospf 1
R2(config-router)#network 172.18.0.0 0.0.0.255 area 0
R2(config-router)#network 10.1.2.0 0.0.0.255 area 0

کانفیگ OSPF روتر R3 :

R3(config)#router ospf 1
R3(config-router)#network 10.1.3.0 0.0.0.255 area 0
R3(config-router)#network 172.18.0.0 0.0.0.255 area 0

کانفیگ OSPF روتر R4 :

R4(config)#router ospf 1
R4(config-router)#network 172.18.3.0 0.0.0.255 area 3
R4(config-router)#network 10.4.1.0 0.0.0.255 area 3
R4(config-router)#network 172.18.13.0 0.0.0.255 area 0

نکته: چون در اینجا روتر R4 ما ABR هست و با area 0 در ارتباط هست ما باید شبکه area 0 و area 3 را جدا وارد کنیم

کانفیگ OSPF روتر R5 :

R5(config)#router ospf 1
R5(config-router)#network 10.4.2.0 0.0.0.255 area 3
R5(config-router)#network 172.18.3.0 0.0.0.255 area 3

کانفیگ OSPF روتر R6 :

R6(config)#router ospf 1
R6(config-router)#network 10.4.3.0 0.0.0.255 area 3
R6(config-router)#network 172.18.3.0 0.0.0.255 area 3

کانفیگ OSPF روتر R7 :

R7(config)#router ospf 1
R7(config-router)#network 172.18.11.0 0.0.0.255 area 0
R7(config-router)#network 172.18.1.0 0.0.0.255 area 3
R7(config-router)#network 10.2.1.0 0.0.0.255 area 3

کانفیگ OSPF روتر R8 :

R8(config)#router ospf 1
R8(config-router)#network 10.2.2.0 0.0.0.255 area 1
R8(config-router)#network 172.18.1.0 0.0.0.255 area 1

کانفیگ OSPF روتر R9 :

R9(config)#router ospf 1
R9(config-router)#network 10.2.3.0 0.0.0.255 area 1
R9(config-router)#network 172.18.1.0 0.0.0.255 area 1

کانفیگ OSPF روتر R10 :

R10(config)#router ospf 1
R10(config-router)#network 172.18.12.0 0.0.0.255 area 0
R10(config-router)#network 10.3.1.0 0.0.0.255 area 2

کار تمام است و حالا باید از هر جای شبکه به شبکه دیگر دسترسی داشته باشیم.

نکته: ما به دو صورت می توانیم به صورت دستی مشخص کنیم که DR و BDR چطور انتخاب شود. در روش اول ما باید روتری که میخواهیم به انوان DR انتخاب شودم را با دستور زیر مقدار router-id بالاتری براش انتخاب کنیم:

R4(config-router)#router-id 200.200.200.200

و با با رفتن به اینترفیس مورد نظر و دستور زیر عدد priority بالاتری برای آن اینترفیس مسخص کنیم. (عدد 0 یعنی هیچگاه DR انتخاب نشود عدد 1 پیشفرض می باشد و هر چه عدد بالاتر باشه اولویت بیشتری برای انتخاب شدن دارد)

R4(config-if)#ip ospf priority 100

حال فکر کنید به شبکه R2 ما بر روی اینترفیس gigabitEthernet 0/1 شبکه LAN قرار دارد و ما دیگر نمیخواهیم پیغام HELLO در این شبکه ارسال شود، پس با دستور زیر این اینترفیس را برای ارسال و دریافت HELLO پروتکل OSPF غیرفعال می کنیم و دیگر از این اینترفیس با هیچ روتری همسایه نمی شود.

R2(config)#router ospf 1
R2(config-router)#passive-interface gigabitEthernet 0/1

دستورات Show برای رفع اشکال OSPF

چنتا از دستورات پرکاربرد را برای شما در زیر قرار داده ایم.

Core-Router#show ip ospf

Core-Router#show ip ospf neighbor

Core-Router#show ip ospf interface

Core-Router#show ip ospf database

Core-Router#show ip protocols

Core-Router#show ip route

Core-Router#show ip route ospf

Core-Router#debug ip ospf adj

آموزش OSPFv3 برای IPv6

روش راه اندازی OSPFv3 خیلی متفاوت از نسخه قبلی آن نیست و فقط چند تفاوت کوچیک داره که پیشنهاد میکنم ویدیویی که در زیر قرار داده ایم را مشاهده کنید.

 
 

OSPF Commands:

area nssa

area nssa translate

area virtual-link

capability vrf-lite

capability vrf-lite (OSPFv3)

clear ip ospf

compatible rfc1587

default-information originate (OSPF)

default-metric (OSPF)

distance ospf

domain-id (OSPFv3)

ignore lsa mospf

ip ospf area

ip ospf database-filter all out

ip ospf demand-circuit

ip ospf flood-reduction

ip ospf name-lookup

ip ospf network

limit retransmissions

log-adjacency-changes

max-lsa

max-metric router-lsa

neighbor (OSPF)

network area

nsf cisco helper disable

nsf ietf helper disable

nsr

redistribute maximum-prefix

router ospf

router-id

show ip ospf

show ip ospf border-routers

show ip ospf database

show ip ospf flood-list

show ip ospf interface

show ip ospf neighbor

show ip ospf nsr

show ip ospf request-list

show ip ospf sham-links

show ip ospf statistics

show ip ospf summary-address

show ip ospf virtual-links

show ipv6 ospf

summary-address (OSPF)

timers lsa arrival

timers pacing flood

timers pacing retransmission

timers throttle spf

نویسندگان
جعفر قنبری شوهانی
منبع
tosinso.comwikipediaaparat.com
برچسب ها

نوشته های مشابه

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

دکمه بازگشت به بالا
بستن
بستن